QGreenland

A Free GIS Package for Greenland

User Guide
Version 1.0.0

QGreenland is a free mapping tool to support interdisciplinary Greenland-focused
research, teaching, decision making, and collaboration. This project is funded by
the U.S. National Science Foundation EarthCube program under grant #1928393.

QGreenland v1.0.0 © NSIDC 2021
https://qgreenland.org | https://github.com/nsidc/qgreenland

Table of Contents
1. Introduction to QGreenland............................................................................................................1		
1.1. About the Project...............................................................................................................1
		1.1.1 What is in the v1.0.0 QGreenland Download Package?................................1
1.2 Licensing, Citing, and Contributing..................................................................................2
1.3 Project Collaborators..........................................................................................................2
2. Getting Started..................................................................................................................................3		
2.1 System Requirements........................................................................................................3
Requirements........................................................................................................3
2.2 Downloading and Installing QGreenland.......................................................................3
QGreenland.......................................................................3
3. Tour the Interface...............................................................................................................................4
Interface...............................................................................................................................4
4. Spatial Data Overview......................................................................................................................6
Overview......................................................................................................................6
4.1 Vector Data.........................................................................................................................6		
Data.........................................................................................................................6		
		
4.1.1 Vector Data Attributes.......................................................................................6
Attributes.......................................................................................6
4.2 Raster Data
Data..........................................................................................................................7
..........................................................................................................................7
4.3 Layer Properties..................................................................................................................7		
Properties..................................................................................................................7		
		4.3.1
		
4.3.1 Data Projections..................................................................................................8
Projections..................................................................................................8
		4.3.2
		
4.3.2 Scale-Dependent Rendering............................................................................8		
Rendering............................................................................8		
4.4
4.
4 QGreenland Data Layers...................................................................................................8
Layers...................................................................................................8
5. Interacting with Geospatial Data in QGreenland.........................................................................9
QGreenland.........................................................................9				
5.1
5.
1 Identifying Features in Layers...........................................................................................9		
Layers...........................................................................................9		
5.2
5.
2 Measuring Distances, Areas, and Angles......................................................................10
Angles......................................................................10
5.3
5.
3 Adding Text Annotations to the Map View...................................................................10
View...................................................................10				
5.4 Editing Layer Symbology................................................................................................11		
5.5 Processing Toolbox..........................................................................................................11		
Toolbox..........................................................................................................11		
5.6
5.
6 Spatial Querying...............................................................................................................11
Querying...............................................................................................................11
5.7 Examples of Simple Querying........................................................................................12
		5.7.1
		
5.7.1 Example 1: Selecting from Vector Layers for Specific Features.................12		
		
5.7.2 Example 2: Vector Layer Statistics..................................................................12
		
5.7.3 Example 3: Simple Raster Analysis.................................................................13
5.7.4 Example 4: Using the Raster Calculator.........................................................14
6. Adding New Datasets to QGreenland.........................................................................................16
6.1
6.1 Uploading New Layers to QGreenland.........................................................................16
QGreenland.........................................................................16				
6.2
6.2 Selecting for Greenland-Specific Data..........................................................................16
Data..........................................................................16
6.3
6.3 Creating a Custom Clipping Boundary Polygon....
Polygon..........................................................17
......................................................17				
6.4
6.4 Editing Vector Data Layers..............................................................................................17
Layers..............................................................................................17				
6.5
6.5 Creating New Shapefiles and GeoPackage Layers from Scratch...............................17
Scratch...............................17				
6.6 Importing GPS and other GNSS Data Using the GPS Plugin.....................................
Plugin..................................... 19
7. Creating a Map for Print or Publication.......................................................................................20
Publication.......................................................................................20				
7.1 Print Layout........................................................................................................................20
Layout........................................................................................................................20
8. Frequently Asked Questions and Troubleshooting...................................................................21
Troubleshooting...................................................................21				
8.1 What if I can’t see any data layers in the map view?....................................................21
view?....................................................21
8.2 Why can’t I find the buttons or toolbars referred to in the user guide?....................21
guide?....................21				
8.3 Why can’t I see a layer in the map view even though it is turned on and I’ve
zoomed to the layer?.............................................................................................................21
layer?.............................................................................................................21
8.4 Navigating QGIS errors....................................................................................................21
errors....................................................................................................21
8.5 How do I contact the QGreenland team?.....................................................................21
9. Appendices.....................................................................................................................................
Appendices..................................................................................................................................... 22		
9.1 Appendix A: Defined Terms............................................................................................22
Terms............................................................................................22
QGreenland v1.0.0 © NSIDC 2021
https://qgreenland.org | https://github.com/nsidc/qgreenland

1. Introduction to QGreenland
Welcome to QGreenland! We hope this project is useful to you, whatever your goals and
purposes. This User Guide is designed to orient the novice QGIS user to the basics of the
QGIS interface and functionality, from data analysis to map making, using the QGreenland
data package. It is not meant to be a complete and advanced guide to QGIS, thus there are
many functionalities within the software that are not covered here but that can be found
in more comprehensive online QGIS manuals. There are a number of online resources to
explore to learn more about QGIS and its functionality, including:
•
•
•
•

QGIS
QGIS
QGIS
More

User Guide: https://docs.qgis.org/3.10/en/docs/user_manual/
Training Manual: https://docs.qgis.org/3.10/en/docs/training_manual/
Tutorials and Tips: https://www.qgistutorials.com/en/
advanced trainings and topics: https://courses.spatialthoughts.com

Additional QGreenland-specific how-to video tutorials are available on the QGreenland
YouTube channel: https://www.youtube.com/channel/UCjWae_Jrbognx2ju_SHBZ2A

1.1 About the Project
QGreenland (https://qgreenland.org) is a free mapping tool to support interdisciplinary
Greenland-focused research, advanced secondary or post-secondary teaching, decision
making, and collaboration. QGreenland consists of a curated collection of geospatial datasets
for Greenland that is hosted on the QGIS platform (www.qgis.org). QGIS is a free and open
source Geographic Information System (GIS) licensed under the GNU General Public License.
QGreenland is designed to be used by a diverse user group, from scientists to planners and
policymakers to educators, and more. QGreenland users are able to produce high-quality
mapping products to meet their unique needs. And because the QGreenland data package
is downloaded right onto the user’s computer, QGreenland can be used in the field and
in remote places without Internet access. Some additional larger datasets (e.g., satellite
imagery) not included with the main QGreenland download package are available through
online access when connected. QGreenland was inspired by the free and open source
Quantarctica GIS data package for Antarctica (https://www.npolar.no/en/quantarctica/).
1.1.1 What is in the v. 1.0.0 QGreenland Download Package?
You will find the following files in the QGreenland data package:
•
•
•
•

•
•
•
•
•
•

Folders containing data layers organized by topic
The main qgreenland.qgs project file
qgreenland.png - The official QGreenland logo
layer_list.csv - A complete list of all the data layers in the QGreenland download
package, including information about each (data source, file size, etc. ). This file can be
opened with Microsoft Excel, LibreOffice Calc, a text editor, or a similar program.
UserGuide.pdf - The full QGreenland User Guide
QuickStartGuide.pdf - A one-page overview guide for experienced QGIS users on how
to download the QGreenland data package and other information
MakingDataQGRCompatible.pdf - A short guide on how to make your datasets
compatible with QGreenland
STYLE.txt - Guidelines and standards for QGreenland data layer styling
CONTRIBUTING.txt - Instructions on how to contribute to the QGreenland project
README.txt - Brief description of the QGreenland data package
QGreenland v1.0.0 © NSIDC 2021
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• CHANGELOG.txt - A log of changes made to the QGreenland data package

Please note that QGreenland v1.0.0 is the first stable public release version from this project.
QGreenland version 1.0.0 will not be the final version of the QGreenland download package.
There will be a version 2.0.0 released some time in 2022 that may include new and updated
layers. Development versions along the way will continue to be available via the website
(http://qgreenland.org), with code fully documented on GitHub (https://github.com/nsidc/
qgreenland).

1.2 Licensing, Citing, and Contributing
QGreenland development is open source and available on GitHub at github.com/nsidc/
qgreenland. This means that users are free to create their own customized QGreenland
package with different and new styles, layers, and data. Users who wish to contribute to the
QGreenland project will find instructions on how to do this in the CONTRIBUTING.txt file
included in the download package and in CONTRIBUTING.MD on GitHub.
QGreenland is licensed under an MIT license:
Permission is hereby granted, free of charge, to any person obtaining a copy of this software
and associated documentation files (the “Software”), to deal in the Software without restriction,
including without limitation the rights to use, copy, modify, merge, publish, distribute,
sublicense, and/or sell copies of the Software, and to permit persons to whom the Software
is furnished to do so, subject to the following conditions: The above copyright notice and this
permission notice shall be included in all copies or substantial portions of the Software.
Users should note that published works produced using QGreenland are required to cite
each dataset used in the work. QGreenland provides all dataset citation information in each
layer’s metadata in QGIS (see section 4.3: Layer Properties for instructions on how to access a
layer’s metadata) and in the layer catalog provided with the QGreenland download package,
layer_list.csv. You are also required to acknowledge or cite QGreenland and the National
Snow and Ice Data Center in your work.
Suggested citation for QGreenland:
Moon, T., Fisher, M., Harden, L., and T. Stafford (2021). QGreenland (v1.0.0) [software],
National Snow and Ice Data Center Available from https://qgreenland.org/.

1.3 Project Collaborators
QGreenland is developed by researchers, software developers, and education specialists
at the National Snow and Ice Data Center and Cooperative Institute for Research in
Environmental Sciences at the University of Colorado Boulder. The QGreenland project is
funded by the U.S. National Science Foundation EarthCube program under grant #1928393.
The QGreenland project is advised by an Editorial Board consisting of international content
experts in remote sensing and GIS, cryospheric and geologic sciences, ecology, climate
modeling, and more. Other project collaborators include: The Geological Survey of Denmark
and Greenland (De Nationale Geologiske Undersøgelser for Danmark og Grønland),
Technical University of Denmark (Dansmarks Tekniske Universitet), Danish Meteorological
Institute (Dansmarks Meteorologiske Institut), Asiaq - Greenland Survey, Norwegian Polar
Institute (Norsk Polarinstitutt), Arctic Data Committee, International Arctic Science Committee,
WWF-Danmark, U.S. Polar Geospatial Center, Greenland Ice Sheet Ocean Science Network,
N.S.F. Polar Computing RCN, and Isaafik. More information about the QGreenland team and
collaborators is available at the website (http://qgreenland.org).
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2. Getting Started
2.1
2.
1 System Requirements
Before downloading the QGreenland data package, be sure that QGIS is installed on your
computer: https://www.qgis.org/en/site/forusers/download.html. QGIS is available on
Windows, macOS, Linux and Android. Note that QGIS version 3.10 is the oldest version
supported by QGreenland.

2.2
2.
2 Downloading and Installing QGreenland
The QGreenland data package is available for download at https://qgreenland.org/
download. After downloading, unzip and save the folder in a location of your choice. Select
the qgreenland.qgs file to open the full QGreenland data package. Files with a ‘.qgs’ or
qgreenland.qgs,, QGIS will open
‘.qgz’ extension are QGIS project files. When you open qgreenland.qgs
automatically and display the QGreenland data environment. Alternatively, you can open the
QGIS software first, then go to ‘Project’ -> ‘Open’ and navigate to the qgreenland.qgs project
file on your computer.
Note: Any changes that are made to the qgreenland.qgs project that are saved will overwrite
the original file; therefore, it is recommended that you save each QGreenland project that you
work on with a new and unique filename (‘File’ -> ’Save as...’).

QGreenland v1.0.0 © NSIDC 2021
https://qgreenland.org | https://github.com/nsidc/qgreenland

3

3. Tour the Interface
In this user guide you will see various screenshots of the QGreenland and QGIS interface.
The screenshots in this guide were generated from QGIS version 3.10 running on a macOS
Catalina operating system; thus, depending on the operating system and QGIS version you
are using, your QGIS interface may look slightly different.
The main components of the QGIS interface are the menu bar, toolbars, panels, status bar,
and map view (Fig. 1):

Fig. 1: Main components of the QGIS/QGreenland interface

The MAP VIEW is the main part of the QGIS/QGreenland interface where the data layers are
displayed. A GIS ‘layer’ refers to a geospatial dataset along with the symbols and labels used
to portray it in a GIS environment. Information about the map view such as its coordinate
reference system, scale, and the coordinates of your cursor’s location as you move it around
the map view are indicated in the STATUS BAR.
The data layers in the current project are listed in the LAYERS PANEL, and, when checked
‘on’, are displayed in the map view in the order that they are listed in the Layers panel (the
layer listed first in the Layers panel is the topmost layer in the map view). If you downloaded
the full QGreenland data package, the Layers panel will show all of the data layers included in
the package. A complete list of all data layers in QGreenland can also be found in the layer_
list.csv file included in the download package. Layers and layer groups (a collection of related
layers nested within a broader group) can be toggled on and off by checking or unchecking
boxes in the Layers panel. When you first open the QGreenland data package, two reference
layers will be automatically toggled on: Greenland coastlines 2017 and the QGreenland
Basemap. Layers can be rearranged by clicking and dragging up or down. Layer groups can
be expanded or collapsed by clicking on the arrow to the left of the checkbox. To expand or
collapse all layers at once, click on the respective buttons (Fig. 2 (a)) right above the layers list
in the Layers panel. In addition to the Layers panel, there are a variety of other panels that can
be displayed on the QGIS interface. For example, the Browser panel provides a shortcut for
QGreenland v1.0.0 © NSIDC 2021
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accessing other data layers or project files on your computer or another location. Panels can
be moved around the interface by clicking and dragging, and can be removed by clicking on
the ‘X’ box in the upper righthand corner.
The TOOLBARS contain buttons that allow the user to interact
with the map view. For example, the hand button (Fig. 2 (b))
in the Map Navigation toolbar lets the user grab and drag the
map view around. The magnifying glass buttons (Fig. 2 (c))
allow the user to zoom in and out or to a particular feature or
selection in the map view. More information about a toolbar
button’s function can be obtained by hovering one’s mouse
over the button. Toolbars can be moved around the QGIS
workspace by clicking and dragging. To toggle a toolbar on
or off, simple right click on a toolbar and check or uncheck the
desired boxes. (Fig. 3).
If data layers are toggled on but not visible in the map view,
the magnifying glass with three arrows (‘Zoom Full’) button
(Fig. 2 (d)) will bring all visible layers back into the map view.
Right clicking on a layer in the Layers panel and selecting
‘Zoom to Layer’ or clicking on the magnifying glass over a
square button (Fig. 2 (e)) in the Map Navigation toolbar will
also bring a desired layer into view in the map view.

Fig. 3:
3 Toolbars can be added or removed by right clicking on the toolbar
area and checking/unchecking boxes.

Finally, the MENU BAR across the top of the QGIS interface provides the user with access to
most QGIS functions, including many that can also be accessed in the toolbars: opening new
or saved projects, saving a current project, adding or creating data layers, analyzing layers,
etc. You can fully customize the look and layout of your QGIS interface by going to ‘View’ in
the menu bar and selecting the panels, toolbars, etc. that you would like visible.

QGreenland v1.0.0 © NSIDC 2021
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4. Spatial Data Overview
There are two main basic kinds of GIS data layers: vector and raster.

4.1
4.
1 Vector Data
Vector data are composed of points, lines, and polygons and represent discrete features.
Examples of vector data are cities (points), roads and highways (lines), and geographic
boundaries like country borders (polygons) (Fig. 4). All of the vector layers in QGreenland are
GeoPackage (.gpkg) files. A GeoPackage is just a platform-independent file type for storing
geospatial data.

Fig. 4: Examples of vector data layers in QGreenland: Points (towns and settlements), lines
(median January sea ice extent), and polygons (country boundaries).

4.1.1 Vector Data Attributes
All QGIS vector data layers have associated attributes, or characteristics of the discrete
features. Attributes can be almost anything: city name, road type (highway, paved, unpaved,
etc.), land elevation value, population density, date, etc. The attributes of a data layer can be
viewed in tabular form by right clicking on the layer in the Layers panel and selecting ‘Open
Attribute Table’ from the menu options, or by clicking on the layer in the Layers panel and
then clicking on the Open Attribute Table button
in the Attributes toolbar. This opens
up an Attribute Table, where the columns are the various fields, or attributes, and the rows
are individual features. Clicking on and highlighting records in the Attribute Table will also
highlight those specific points, lines, or polygons in the map view. Right-click any cell to
‘Zoom to feature’, ‘Pan to feature’, or ‘Flash feature’.

QGreenland v1.0.0 © NSIDC 2021
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4.2
4.
2 Raster Data
Raster data are composed of grid cells or pixels, where each grid cell has its own value.
Rasters represent continuous data, such as land elevation, surface temperature, land cover,
etc. (Fig. 5). The resolution, which is the length of the grid cell sides of each raster dataset in
QGreenland, is indicated in the name of the dataset, e.g.: “Ice Sheet Velocity (500 m)”. Raster
layers in QGreenland are all GeoTIFF files, which are images with geographic features, such
as geospatial metadata and overviews/tile pyramids.

Fig. 5: Example of a raster data layer in QGreenland, ice sheet velocity, where
each grid cell in the raster is 500 m x 500 m and is color-coded by a velocity

4.3
4.
3 Layer Properties
Right clicking on a data layer in the Layers panel and selecting ‘Properties’, or simply double
clicking on a layer in the Layers panel will bring up the Layer Properties dialog window,
which contains a variety of information about a layer (Fig. 6). The information is organized
into sections (or tabs) that can be accessed by clicking on an individual tab (e.g., Symbology)
in the left sidebar of the window. The tabs listed in a vector Layer Properties dialog window
differ slightly from those listed for a raster layer. The tabs most relevant to a novice QGIS user
and that exist for both vector and raster layers are:
• Information: This section summarizes information about a layer, including its name, coordinate
reference system, spatial extent (geographic boundaries), description (abstract), and more.
• Symbology: Every QGreenland data layer has a predefined symbology, or visual representation
in the map view. See section 5.4: Editing Layer Symbology for instructions on how to modify or
customize a layer’s symbology.
• Metadata: Metadata is essentially “data about data”. In QGIS, layer metadata is information about
the data in the layer, including its name, description, citation, and link to the source that the data
was retrieved from. As outlined in section 1.2: Licensing, Citing, and Contributing, published
works produced using QGreenland are required to cite each dataset used in the work. Users can
thus simply copy a layer’s citation directly from its metadata. An abbreviated version of a layer’s
metadata can also be viewed by selecting a layer in the Layers panel and hovering your mouse
over the layer name.

Note: The QGreenland team has in a few instances included comments on ‘Noted Data Issues’.
Read about ‘Noted Data Issues’ in the layer metadata. These are currently noted for the ‘Towns
and settlements’ and the ‘Community map (crowdsourced)’ layers. Regardless, QGreenland
makes no guarantees about the accuracy and validity of data contained in QGreenland.
QGreenland v1.0.0 © NSIDC 2021
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Fig. 6: The Layer Properties dialog window for the QGreenland ‘Earthquakes’ data layer

4.3.1 Data Projections
Data projections, or Coordinate Reference Systems (CRS), define the coordinate system for
a QGIS project and data layers. The CRS for the current map view is indicated on the right
side of the QGIS status bar. For QGreenland, the current CRS should be identified as ‘EPSG:
3413,’ which is the identifier for the NSIDC Sea Ice Polar Stereographic North on a WGS 84
Ellipsoid CRS. Changing the CRS of the map view will not change the source CRS of data
layers in the project (called ‘reprojection’). It is possible to reproject a layer into a new CRS;
however, this transforms the data and can introduce artifacts. Therefore, it is recommended
that to reproject data, the user do so from the source data and not the data contained in the
QGreenland package.
4.3.2 Scale-Dependent Rendering
Scale-dependent rendering refers to the scale at which a particular data layer will be visible in
the QGIS map display. This can make it easier to zoom in and out for certain data layers. The
user can turn on scale-dependent rendering for any layer by going to the layer ‘Properties’ ->
‘Rendering’, checking the box for Scale Dependent Visibility, and then setting the minimum
and maximum scale dependent visibility. For scale reference, refer to the scale indicated at
the bottom of the QGIS interface in the Status Bar.

4.4
4.
4 QGreenland Data Layers
A complete list of all QGreenland data layers and their metadata, including information about
their original data source, can be found in the layer_list.csv file included in the QGreenland
download package.
QGreenland v1.0.0 © NSIDC 2021
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5. Interacting with Geospatial Data in QGreenland
5.1
5.
1 Identifying Features in Layers
One of the most basic ways to interact with data in QGIS is to use the Identify Features
button in the Attributes toolbar to quickly view the attributes of an individual record (i.e., a
single point, line, or polygon in a vector layer or a single cell in a raster layer). Note: If you do
not see this button in any of your toolbars, then you need to toggle on the Attributes toolbar.
Either right click anywhere in the toolbar area and check the box next to ‘Attributes toolbar’,
or go to ‘View’ -> ‘Toolbars’ in the menu bar.
To use the Identify Features button:
1. First, make sure that the layer (not just layer group) that you are interested in
is toggled on and selected (click on it so that the layer is highlighted) in the
Layers panel.
2. Click on the Identify Features button in the Attributes toolbar.
3. Click on the individual point, line, polygon, or raster cell of interest in the map
view. The record for the object selected will show up in a new Identify Results
panel to the right of the map display (Fig. 7).
4. You can choose what information the Identify tool is showing you and how it is
displayed by toggling the Mode and View options at the bottom of the Identify
Results panel.

Fig. 7:
7 The Identify Results panel that shows results from the Identify Features tool.
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5.2
5.
2 Measuring Distances, Areas, and Angles
Another useful basic tool in the Attributes toolbar is the measuring tool
. The measuring
tool is a quick and easy way to measure distances between two points or along a line, area of
a polygon, or angles between geographic features or locations.
To use the measuring tool:
1. Click on the arrow to the right of the measuring tool button and choose if you
want to measure a line, area, or angle. Regardless of which one you choose, a
small window will appear.
2. If you are measuring a line distance, first choose your desired units (e.g.
kilometers). Ellipsoidal measurements take into account the spherical
shape of the earth and the project’s coordinate reference system. Cartesian
measurements assume a flat Earth. For small distances, these numbers will be
very similar, but for very large distances they can be very different.
3. Clicking first on one point on the map and then another will draw a line
segment whose length will be indicated in the ‘Segments’ box. You can draw
and measure multiple line segments.
4. To clear the segments you’ve drawn, click on ‘New’.
5. To measure an area instead of a line with the measuring tool, you will follow
essentially the same steps for measuring a line distance, except you will click
and map out an area on the map instead of drawing line segments.
6. To measure the angle created by three points on the map, click on each of the
three points to draw the angle. The second point you click on will serve as the
angle’s vertex.

5.3
5.
3 Adding Text Annotations to the Map View
You can add a text annotation anywhere in the map view using the text annotation tool
in the Attributes toolbar.

To use the text annotation tool:
1. Click on the text annotation button in the Attributes toolbar.
2. Click on the place on the map where you want the text annotation to go. A
small white box will appear.
3. Double click on the box to open a new window where you can write your
annotation and choose the font you want to use, among other things (e.g., you
can link the annotation to a specific layer).
4. When you’re done, click ‘Apply’ and then ‘Ok’ to close the window.
5. To delete an annotation, double click on it to open the dialog window, then
click ‘Delete’.
QGreenland v1.0.0 © NSIDC 2021
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5.4
5.
4 Editing Layer Symbology
Each QGreenland data layer comes with a predefined symbology (how the layer is visualized
in the map view).

To modify a layer’s symbology:
1. Open the Layer Properties dialog window for the layer you want to edit.
2. Go to the ‘Symbology’ section and modify the layer symbology as desired.
a) For a vector layer, you can choose from a built-in set of QGIS symbols, and/
or can change individual characteristics of the layer’s symbology such as
symbol shape, weight, color, size, opacity, and more.
b) For a raster layer, you can change the color properties of the grid cells, as
well as characteristics like brightness and contrast. The opacity/transparency of
a raster layer can be changed in the Transparency tab of the Layer Properties
dialog window.

5.5
5.
5 Processing Toolbox
The Processing Toolbox is what makes the QGIS platform a powerful spatial data analysis tool.
The Toolbox is a collection of tools and prewritten algorithms that allow the user to perform a
wide variety of raster and vector data analyses. For example, the Processing Toolbox contains
tools for identifying features in a vector layer that fulfill certain criteria, extracting selected
features from a vector layer and saving them as a new layer, and calculating vector and raster
layer statistics. The Processing Toolbox can be opened in a new panel to the right of the map
view by clicking on the gear icon
in the Attributes toolbar or by going to ‘View’ -> ‘Panels’
-> ‘Processing Toolbox Panel’ in the menu bar.
For more in-depth information about the Processing Toolbox see: https://docs.qgis.org/3.10/
en/docs/user_manual/processing/toolbox.html

5.6
5.
6 Spatial Querying
Spatial querying allows the user to select specific layer features based on desired parameters,
or compare features from one layer with features from another layer based on their
spatial relationships or common parameters. Below we describe a specific set of steps for
completing various example query and analysis tasks; however, the QGreenland user will
learn through experience that there is very often more than one way to complete a desired
task in the QGIS platform. We will describe several query and analysis methodologies that
use the QGIS Processing Toolbox.

QGreenland v1.0.0 © NSIDC 2021
https://qgreenland.org | https://github.com/nsidc/qgreenland

11

5.7
5.
7 Examples of Simple Querying
5.7.1 Example 1: Selecting from Vector Layers for Specific Features
Which populated regions in Greenland have more than 5000 people?
1. Open the Processing Toolbox and go to ‘Vector selection’ -> ‘Select by
attribute’.
2. Fill in the following parameters:
-Input layer = Populated places
-Selection attribute = population
-Operator = ‘>’
-Value = type in ‘5000’
-Modify current selection by = creating new selection
These parameters are telling the program to identify all of the populated places in
Greenland that have a population greater than 5000.
3. Click on ‘Run’. The window will automatically close when processing is
complete.
There are a couple of ways to view the selected data points, populated places in Greenland
with more than 5000 people. First, you should see the places that meet this parameter
highlighted in the map view (make sure the Populated places layer is toggled on). You can
also open the Populated places layer Attribute Table and select ‘Show Selected Features’ in
the bottom left corner. This will hide all records in the layer Attribute Table except for the ones
you selected, the locations with populations greater than 5000 people.
If you want to create an entirely new layer based on this feature selection (population>5000),
you can do so by either 1) right-clicking on the layer you have just selected from and
choosing ‘Export’ -> ‘Save selected features as…’, or by 2) selecting ‘Extract by attribute’
under ‘Vector selection’ in the Processing Toolbox.
5.7.2 Example 2: Vector Layer Statistics
What is the total number of people in Greenland’s populated areas?
What is the average size of Greenland’s populated areas?
1. Open the Processing Toolbox and go to ‘Vector analysis’ -> ‘Basic statistics for
fields’.
2. Fill in the following parameters:
-Input layer = Populated places
-Field to calculate statistics on = population
-Statistics = Save to temporary file (or whatever your preference is)
3. Click ‘Run’.
The vector analysis window should automatically switch to a view of the Log where you will
see the results for the population basic statistics (Fig. 8). The value ‘MEAN’ will tell you the
average size of Greenland’s populated places (1102 people). The value ‘SUM’ will tell you the
total number of people in Greenland’s metropolitan areas (48,492 people).
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Fig. 8: Results of Example 2: Vector Layer Statistics

5.7.3 Example 3: Simple Raster Analysis
What is a good estimate of the Greenland ice sheet’s volume?
1. In the Processing Toolbox, go to ‘Raster analysis’ -> ‘Raster surface volume’. This
is an algorithm that calculates the volume under a raster grid’s surface.
2. Fill in the following parameters:

-Input layer = Ice thickness (500
(500 m)
m)
-There will only be one option for Band number
-Base level = should already be set to 0 This is the minimum pixel value in the Ice
thickness layer.
-Method = Count only above base level (since we are interested in ice thickness values
greater than zero)
-Save the Surface volume report, the output for this algorithm, in a temporary file or in a
desired location on your computer.

3. Click ‘Run’ and close the Raster surface volume window.
4. You should now see a panel underneath the Processing Toolbox called Results
Viewer (Fig. 9), which will direct you to the location of the results html file for
this calculation. Open the file.

The results file should contain three numbers: volume, pixel count, and area. The volume is
the volume of the Greenland ice sheet in units of m3. The results should show that the Greenland ice sheet has a volume of 2,947,732,015,000,000 m3, or about 2.9 million km3.
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Fig. 9: To view the results of the raster surface volume analysis, click on the link
next to ‘File path’ in the Results Viewer panel below the Processing Toolbox.

5.7.4 Example 4: Using the Raster Calculator
How does the maximum sea ice concentration (%) around Greenland and
the surrounding land masses in 2020 compare to the maximum sea ice
concentration a decade earlier (2010)?
The raster calculator is a tool that allows you to perform calculations on one or
more raster layers. For example, if you wanted to convert a raster layer that is in
km2 to mi2, you could use the raster calculator. In this example, we’re going to use
the raster calculator to subtract one layer from another. Note: There is a different
Raster calculator that can be accessed in the menu bar by going to ‘Raster’ ->
‘Raster calculator’. This calculator is different from the one in the Processing
Toolbox used in this example:
1. In the Processing Toolbox, go to ‘Raster analysis’ -> ‘Raster calculator’.
2. In the window that appears, you are going to build a mathematical expression
using the layers and operators in the Expression box:
a) In the Layers box, scroll down and double click on the March2020@1 layer (this
is the layer for the NSIDC’s sea ice concentration data from March 2020). You
should see it show up in the Expression box in quotations (“ “).
b) Either type in the minus (-) symbol or click on it under Operators. It should show
up after the layer you just chose.
c) In the Layers box, scroll to and double click on the March2010@1 layer. It should
show up after the minus sign, again in quotations (Fig. 10).
d) For Reference layer, it’s recommended you choose either of the two layers used
in the expression. Click on the three dots […] which will open up another window
and allow you to choose the reference layer by checking the box next to the layer
name.

3. Click ‘Run’ and close the window.
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Fig. 10: The Raster calculator expression for Example 4.

The output layer will appear in the layers panel (likely named ‘Output’). You can right click on
it and rename it if you like. The values next to the colored boxes below the output file (likely
black and white boxes) will tell you the minimum and maximum values of the resulting raster
layer. In this case, the numbers will be the difference in the maximum sea ice concentration
(%) between 2010 and 2020, where positive values indicate an increase between 2010 and
2020 (endmember = +80%), and negative values indicate a decrease (endmember = -95%).
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6. Adding New Datasets to QGreenland
Once the QGreenland package is downloaded onto a user’s computer, it is fully customizable
by the user. One can add new data, delete layers within QGreenland, or make changes.
Saving the project will update the qgreenland.qgs project file. If you don’t want to overwrite
the original project version, simply save your updated project using a new filename via ‘Save
As…’ You can create as many different projects as you like, adding or removing data from the
downloaded QGreenland package or adding data from elsewhere on your computer.

6.1
6.
1 Uploading New Layers to QGreenland
To add new data layers to QGreenland:
1. In the menu bar, go to ‘Layer’ -> ‘Add Layer’, and choose the layer type you
want to add. Alternatively, you can either click on the desired add layer button
in the toolbar, or click on the Data Source Manager button
in the Data
Source Manager toolbar.
2. Any option you choose will open the same Data Source Manager window. On
the right side of the window, you can double check that the layer type you want
to add is highlighted.
3. Navigate to the data file that you want to add as a layer, then click ‘Add.’

6.2
6.
2 Selecting for Greenland-Specific Data
Because the geographic extent of some QGreenland data layers extends beyond the
geographic and political border of Greenland to include the surrounding water bodies
and land masses, it might sometimes be necessary to filter out certain data if one is only
interested in data within Greenland’s geographic boundary. You can do this using the
Greenland coastlines 2017 polygon layer.
To filter out data outside of Greenland:
1. Make sure that the group you want the filtered/extracted data to be added to is
selected/highlighted in the Layers panel.
2. Open the Processing Toolbox and go to ‘Vector selection’ -> ‘Extract by location’.
3. Fill in the following parameters:
-Extract features from = the data layer you want to filter, for example, Ice cores
-Where the features (geometric predicate) = are within (you can also check intersect and
others to capture data that might be located along the Greenland coastline)
-By comparing to the features from = Greenland coastlines 2017
-Extracted (location) = You can either save the file output from this as a temporary layer
or as a permanent layer somewhere on your computer or within your QGreenland data
package. Note: If you try to save the file as a GeoPackage layer (GPKG) and receive an
error, try again and save it as a Shapefile (SHP) instead.
4. Click ‘Run’ and close the window.
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The filtered data will show up in the Layers panel within the group you had selected and likely
named ‘Extracted (location)’. You can rename the layer by right clicking on it and selecting
‘Rename Layer’.

6.3
6.
3 Creating a Custom Clipping Boundary Polygon
You can create your own custom boundary polygon layer to extract features from. Follow the
instructions in section 6.5: Creating New Shapefiles and GeoPackage Layers from Scratch
to draw a polygon layer from scratch. Then, follow the instructions in section 6.2 Selecting
for Greenland-Specific Data to extract features from your custom polygon boundary layer;
however, instead of comparing features from the Greenland coastlines 2017 layer, you will
instead select the new custom boundary layer.

6.4
6.
4 Editing Vector Data Layers
How do you add or delete points, line segments, or polygons to/in an existing vector layer in
your QGreenland project?

To edit a vector layer:
1. Select the layer you want to edit in the Layers panel (click on it so that it is
highlighted).
2. Toggle into editing mode by either right clicking on the vector layer you are
editing in the Layers panel and selecting ‘Toggle Editing,’ or by clicking on the
Toggle Editing button
in the Digitizing toolbar.
3. With Editing on, you will have access to new editing buttons in the Digitizing
toolbar:
Add new points to a point vector layer
Add new lines to a line vector layer
Add new polygons to a polygon vector layer
4. Whenever you create any new vector feature, you will be prompted to enter
attribute information for the new feature for its record in the layer’s Attribute
Table.
5. If you just want to edit a record in a vector layer’s Attribute Table, you can open
the Attribute Table and click on the Toggle Editing icon in the table toolbar. Be
sure to save the layer edits
after you’re done making edits.
6. When you’re finished, click on the Toggle Editing button again in the toolbar to
disable editing.

6.5
6.
5 Creating New Shapefiles and GeoPackage Layers from Scratch
In your QGreenland project, you may want to create a new vector layer from scratch, such as
a point shapefile of potential study sites for your research in Greenland. To draw a new vector
layer from scratch, you can either create a new shapefile or a new GeoPackage.
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To create a new shapefile layer:
1. Go to ‘Layer’ -> ‘Create Layer’ -> ‘New Shapefile Layer’ in the menu bar or click
on the New Shapefile Layer button
in the Data Source Manager toolbar.
2. In the new window, specify the properties of your new layer, including giving it
a name, specifying its geometry (point, line, polygon) and coordinate reference
system (the coordinate reference system for all QGreenland data layers is
EPSG: 3413).
3. In the same window, create each field for your new layer’s Attribute Table under
“New Field”. You will need to specify whether the new field will contain text data
(string), whole number data (integer), decimal number data (real), or a date.
When you click “Add to Fields List”, the new field will show up in the Field List
below.
4. If you have a layer group highlighted in the Layers panel when you create
the new layer, the new layer will be automatically nested into the highlighted
group. You can move it out of the group by right clicking on the new layer and
selecting ‘Move Out of Group.’
5. Once the new layer has been created, add new features to it using the
processes described in section 6.4: Editing vector data layers.

To create a new GeoPackage layer:
1. In the menu bar, go to ‘Layer’ -> ‘Create Layer’ -> ‘New GeoPackage Layer’ or
click on the New GeoPackage Layer button
in the Data Source Manager
toolbar.
2. A GeoPackage is a GIS file format that allows you to save multiple layers in one
file; thus, you will actually be creating a new GeoPackage database that your
new GeoPackage layer will live in. In the new window:
-Name your new Database
-Name the new GeoPackage layer you are creating - this is the ‘Table name’
-Specify the geometry of the new GeoPackage layer (point, line, etc.)
-Specify the layer coordinate reference system
-Create the fields that will be in the layer’s Attribute Table by giving them a
name and indicating their type (text data, integer, etc.) under ‘New Field’. When
you click on ‘Add to Fields List’, the new field will show up in the Fields List box.
3. Click ‘Ok’. Your new layer will appear in the Layers panel. If it is within another
Group you do not want it in, right click on it and select ‘Move Out of Group.’
You can also drag and drop your layer into the location you want it.

In addition to shapefiles and GeoPackages, there are additional new layer types that can be
created also, such as SpatialLite Layer and Virtual Layer. Descriptions for all layer types can be
found in Appendix A: Defined Terms.
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6.6 Importing GPS and other GNSS Data Using the GPS Plugin
Importing GPS (Global Positioning System) or other GNSS (Global Navigation Satellite
System) data into QGIS requires an internal plugin. A plugin is just a new feature or function
that you can add to QGIS that does something one of the built-in tools doesn’t do. Many
plugins are ‘external’ meaning they are not developed and maintained by the QGIS
development team. Some plugins, however, are ‘core’ meaning they are maintained by the
QGIS team. The GPS plugin is a core plugin and should already be installed in your version of
QGIS.
To turn on the GPS plugin:
1. Go to ‘Plugins’ -> ‘Manage and Install Plugins’ in the menu bar.
2. Click on ‘Installed’ in the left sidebar, then check the box next to ‘GPS Tools’ in
the plugin list. If it is already checked, don’t change anything.
3. Click ‘Close’.
You can import GPS data either directly from a GPS device that is connected to your
computer, or from a file on your computer. Note that QGIS uses the GPX file format for GPS
data, although you can import GPS data that is not GPX (see #2c below).
To import GPS or GNSS data using the GPS plugin:
1. Go to ‘Vector’ -> ‘GPS Tools’ in the menu bar.
2. In the window that pops up, click on the tab most appropriate for the data you
want to import.
a) If you are importing GPS data from a file on your computer, click on the ‘Load
GPX file’ tab and navigate to the file on your computer. Indicate which feature
types you want to load from the file (waypoints, routes or tracks), then click ‘Ok’.
Each feature type you selected will be loaded in a separate layer.
b) If you want to import data directly from a GPS device, click on the ‘Download
from GPS’ tab.
		
		

i) Select the GPS device you are importing from, the port the device is
connected to, and what feature types you want to download.

		
		

ii) Give the data a layer name, which is what it will show up as in the
Layers panel.

		
		
		

iii) The output file is where the downloaded data from your device will
be stored on your computer. Click ‘Ok’. The data should appear as a
new layer in the Layers panel.

c) To import GPS data that is not in the GPX file format, click on the ‘Import
other file’ tab and fill in the relevant information.
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7. Creating a Map for Print or Publication
7.1 Print Layout
Once you’ve created a map in the QGIS map view that you would like to print or publish, you
need to switch to the QGIS print layout, where you will be able to create and customize your
map.
To create a map for print or publication:
1. Go to ‘Project’ -> ‘New Print Layout’ or click on the New Print Layout button
in the Project toolbar. You will have the option to name your new print layout.
2. When the print layout window opens, it will be initially blank. To change the
size and orientation of your print layout, right click in the layout area and
choose ‘Page Properties.’
3. To add a map to your layout, click on the Add Map button
and click and
drag to create a box where the map will appear on the print layout display. To
zoom in on the region shown in the box or change what region is shown, you
can click on the Move Item Content button
, which will make it possible to
manipulate the map area within the box.
4. Add map components such as a north arrow, scale bar, legend, or image to
your print map by either using the appropriate buttons in the Toolbox toolbar
or by going to ‘Add Item’ in the menu bar.
For more detailed information on creating a map for print or publication, see https://docs.
qgis.org/3.10/en/docs/training_manual/map_composer/map_composer.html
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8. Frequently Asked Questions and Troubleshooting
8.1 What if I can’t see any data layers in the map view?
Double check that the layer(s) you wish to view in the map view are checked on in the Layers
panel. Note: Toggling on a main Layer Group won’t necessarily toggle on all individual layers
within the group. Right click on a layer you wish to view and select ‘Zoom to Layer’, or click
on the Zoom Full button
in the Map Navigation toolbar to zoom to the full extent of the
QGreenland data layer package.
8.2 Why can’t I find the buttons or toolbars referred to in the user guide?
Right click on the toolbar area in the QGIS interface and check the toolbars you wish to turn
on so that they are displayed. You can also go to ‘View’ -> ‘Toolbars’ in the menu bar.
8.3 Why can’t I see a layer in the map view even though it is turned on and I’ve zoomed to the
layer?
Double check that there isn’t another layer overlaying and thus obscuring the layer you want
to see in the map view. Remember that layers are displayed in the map view in the order that
they are listed in the Layers panel - layers listed at the top in the Layers panel show up on top
in the map view. You can either turn off any layer that might be obscuring the layer you wish
to see by unchecking it in the Layers panel, or rearrange the order of layers by clicking and
dragging them up or down in the Layers panel.
8.4 Navigating QGIS errors
If you are opening QGIS using a terminal or using the QGIS Python console, it is possible you
might see one of a few different error messages while using QGIS that the QGreenland team
has determined can be ignored:
Warning: Logged warning: Creating Warped VRT
This error message is likely triggered by a raster layer in the QGreenland project but
should not have any impact on the data layers or project usability.
ERROR: Too many connections: max 64
This error is thought to be related to the GeoPackage file format but should not have any
impact on the layers themselves or the project usability.
8.5 How do I contact the QGreenland team?
If you have feedback on or questions about the QGreenland data package or want to
contribute datasets for future QGreenland releases, you can send an email to: qgreenland.
info@gmail.com

Note: This list of QGreenland FAQs will be frequently updated on the QGreenland website for a more up-to-date list of FAQs, go to https://qgreenland.org.
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9. Appendices
9.1 Appendix A: Defined Terms
• Attribute: Information about the components of a vector layer listed in tabular form. For
example, a possible attribute of a point vector layer of cities is city name or population.
• Coordinate Reference System (CRS): The system used to reference the x and y
coordinates of a dataset.
• Layer: A set of data and its symbology.
-GeoPackage
-GeoPackage Layer:
Layer: A collection of one or more data layers, including points,
lines, and polygons, that are saved as a single file. A GeoPackage layer is an 			
open format and platform-independent using SQLite.
-Shapefile
-Shapefile Layer: A proprietary vector layer format (points, lines, polygons)
developed and regulated by Esri, but usable in QGIS.
-SpatialLite
-SpatialLite Layer:
Layer: A way to store an entire spatial database in one file; a spatial
extension to SQLite, a relational database management system.
-Temporary
-Temporary Scratch Layer: A temporary layer formed as a result of a spatial
query of analysis that is discarded when QGIS is closed.
-Virtual
-Virtual Layer: A specific kind of vector layer that results from an SQL query.
• Layer Group: A collection of multiple layers that are related to one another.
• Raster: A layer type consisting of grid cells or pixels, where each cell has a specified
value.
• Vector: A layer type consisting of either points, lines, or polygons, where each point,
line, or polygon has a unique set of attribute values.
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